Training & Documentation

Enterprise Systems

Ithaca College uses several "enterprise" systems to manage the business functions of the college:

  • HomerAdmin (student information system)
  • Parnassus (human resources and financial services)
  • ACE and Argus (business intelligence and reporting)
  • Discoverer (reporting tool)
  • Advance (Institutional Advancement)
  • Nolij Web (electronic document management)


ITS suggests using a Windows computer and Internet Explorer (IE) or Firefox whenever possible. Google Chrome is not compatible with these systems because it blocks the Java plug-ins that are required.

Oracle recommends that if you are a Mac user and have trouble using enterprise applications, consider setting up a virtual Windows workstation and installing Office 2010 or Office 2013. ITS can help you do this. Mac users will need to purchase Fusion but ITS can install the Windows operating system and Office applications (Word, PowerPoint and Excel) under the Ithaca College Campus Agreement with Microsoft.

Mobile devices like smartphones, iPads and tablets use a simplified web interface. These systems may not be able to provide the advanced functionality of the enterprise systems.


The enterprise systems use a Web browser, and due to frequent browser updates, functionality of the enterprise systems with your preferred browser may be impacted unexpectedly when a new update is released.

Windows - Internet Explorer or Firefox are recommended.
Mac - Safari or Firefox are recommended.

If your preferred browser doesn't work, you may have to try a different browser.


  Windows XP Windows XP Windows 7 Windows 7 Windows 8*
  Browser Java Browser Java  
HomerAdmin IE 8 or Firefox 8 IE 9 or 11 in compatibility view
8 N/A
Parnassus IE 8 or Firefox 8 IE 9 or 11 in compatibility view
8 N/A
ACE/Argus IE 8 or Firefox 8 IE 9 or 11 in compatibility view
8 N/A
Discoverer IE 8 or Firefox 7 update 21 IE 9 or 11 in compatibility view
7 Update 21 N/A
Advance IE 8 or Firefox N/A IE 9 or 11 in compatibility view
Nolij Web IE 8 or Firefox 8 IE 9 or 11 in compatibility view
8 N/A

*Windows 8 is not supported for enterprise systems at this time.

Java 8 Update 51, Changing Settings for HomerAdmin Compatibility

The most recent update of Java 8 (Update 51) requires changing some Java settings in order to allow functionality with HomerAdmin. Change the settings as follows:

  • Exit your Web browser
  • Open the Java Control Panel
    • [Windows] Go to the Start button > Control Panel > Java
    • [Mac] Go to the Apple Menu > System Preferences > Java
  • Click the Advanced tab
  • In the Advanced Security Settings section, uncheck all boxes except "Use TLS 1.0".
  • Click OK
  • HomerAdmin should now work correctly.

Internet Explorer and Compatibility View

For better compatibility with enterprise systems it may be necessary to use IE in "Compatibility View".

Adding Website to Internet Explorer Compatibility View,

  1. Open Internet Explorer.
  2. Click Tools in the menu bar. (note: If you do not see the Tools menu, right-click the title bar of and select “Menu bar.”)
  3. Click Compatibility View Settings.
  4. Type the URL into the “Add this website” field and click Add.
  5. Repeat Step 4 for any additional URLs

Internet Explorer and Trusted Sites

When using Internet Explorer 9 and above, this site,, may need to be added to the “trusted sites”. To do this:

  1. Open browser window
  2. Go to Tools
  3. Click on the Security tab
  4. Click on Trusted Sites
  5. Click on Sites
  6. Type the URL into the area for the website url
  7. Click Add
  8. Click Close
  9. Click OK

Firefox and Exceptions

When using Firefox, this site, will need to be added to the “Exceptions List”. To add to the Exceptions List:

  1. Open a Firefox browser window
  2. Click on Tools
  3. Click on Options
  4. Click on Security
  5. Click on the Exceptions button
  6. Enter the url into the address window
  7. Click Allow
  8. Click Close
  9. Click OK

Macs: Browsers and Java:

  OS 10.6 - 10.10  
  Browser Java
HomerAdmin Safari or Firefox 8
Parnassus Safari or Firefox 8
ACE/Argus Safari or Firefox 8
Advance Safari or Firefox N/A
Nolij Web Safari 8

Pop-Up Blockers

Make sure pop-ups are allowed in your browser.